A downloadable project for Windows and Linux

Download NowName your own price

Here you can find plugins for Laigter!

StatusReleased
CategoryOther
PlatformsWindows, Linux
Rating
Rated 5.0 out of 5 stars
(2)
Authorazagaya

Download

Download NowName your own price

Click download now to get access to the following files:

Normal Brush Plugin Linux
HSPO Brush Plugin Linux
Texture Brush Plugin Linux
HSPO Brush for Windows 263 kB
Normal Brush for Windows 275 kB
Texture Brush for Windows 375 kB

Comments

Log in with itch.io to leave a comment.

The brushes do not install. I go to install plugin, find the plugin files, and nothing happens. Any help much appreciated. Thank you

thats strange. Would you double check you are using same version of both plugins and Laigter?

I'm using Laigter 1.10.5 for windows, and the brushes for windows.

I'll check today and get back to you.

Thank you! Really enjoying Laigter! :)

Would you try now? first, delete the currently installed plugins with the toolbar button in Laigter, then redownload the files and try again. I just updated them.

I have the same problem, with windows and the same version as jrockpsycho.

Would you try now? first, delete the currently installed plugins with the toolbar button in Laigter, then redownload the files and try again. I just updated them.

Also, it may worth trying when installing the new plugins i just uploaded, that if nothing happens press refresh plugins a couple times (sorry but sometimes happens)

Thanks for quick response, it is working now!

Cool! Im glad to help!

(+1)

Linux users, this happened to me running the Laigter appimage so FYI:

If you attempt to add any of the Laigter .so-file plugins from this page, and it crashes Laigter, and then continues to crash on app startup, you will need to remove the .so plugin files auto-copied to your home directory to allow Laigter to start normally.

You will find the .so plugin files at:

/home/[you]/.local/share/laigter/plugins

Go ahead and delete whichever last plugin you activated which caused the crash.  You should now be able to run Laigter again.

For me, all three linux plugins from this itch-io page crashed Laigter.  However, the .so files for the three plugins found on their github pages installed and worked fine with no crashes:

https://github.com/azagaya/LaigterNormalBrushPlugin/releases/download/continuous...

https://github.com/azagaya/LaigterTextureBrushPlugin/releases/download/continuou...

https://github.com/azagaya/LaigterHSPOBrush/releases/download/continuous/libhspo...

so it looks like the issue lies with the itch.io download versions.

oh, thanks for reporting this. I will check the versions today. Im sorry if this caused much trouble to you. You are using the latest laigter version?

Hey! I've just tried on Ubuntu 20.04, with Laigter 1.10.2 from itch, and the latest brushes from this page and it works for me. I noticed you are downloading the "continuous" release of the plugins from github... Is it possible that you are also using the continuous release of Laigter from github?

> Is it possible that you are also using the continuous release of Laigter from github

Ah yes, that is likely.  Makes sense that you can't mix and match plugin files from the two different sources.  The appimage I'm running says 1.10.2-beta.  Does the continuous build share the same release version as the itch.io release?

It's likely that I forgot to change the version in the continuous build, as I usually change it when releasing the real version. Continuous is just a build of the current unstable version for testing of new features. But I should change, as stating 1.10.2 in the continuous is actually wrong. Thanks for letting me know that!.

Once I finally manage to make a stable release (i.e. no more beta) plugins should remain the same across minor versions. But as I'm still working on new features that change how maps are rendered, plugins need to be changed too and stop being compatible. 

Also, I should probably find a way to make laigter don't crash with the wrong version of the plugin.

(1 edit)

The normal brush does not seem to work as intended for me.
The color sphere is way off somehow?

This is in windows 10.

are you using intel graphics card? There seems to be a problem with intel windows drivers, as this does not hapen in ubuntu. Do you have a dedicated graphic card to test with?

(1 edit)

I have an NVidea Quadro M1000M and an Intel graphics card both, according to my system.

I configured Laigter to use the Nvidea and this solved the problem 👍

Thanks for the help!

No problem! anyways, i should try to work arround that, for users that don't have another card.

(+1)

Awesome!

(+2)

thanks!